Saruman’s Army

Time Limit: 1000MS Memory Limit: 65536K

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

思路:

先找一段中的第一个数,然后找下一个和这个数超过R的数,记录这个数,这个数的前一个就是一段中的中心点,然后找下一个和他超过R的数,若是有,则说明还有其他部队需要那啥,若是没有则说明,则这就是最后一批,后面已经没有循环了

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main() {
	int n, m;
	while (cin >> n >> m && n != -1 && m != -1){
		vector<int> a(m);
		for (int i = 0; i < m; i++) cin >> a[i];
		sort(a.begin(), a.end());
		int ans = 0, i = 0;
		while (i < m) {
			int s = a[i++];
			while (i < m && a[i] - s <= n) i++;
			int x = a[i - 1];
			while (i < m && a[i] - x <= n) i++;
			ans++;
		}
		cout << ans << endl;
	}
	return 0;
}