题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1241
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Problem solving report:

Description: 有一块n×m的土地,‘@’为油田,‘*’为空地,油田周围8个方向如果也有油田,那么算作一块油田。问这块土地上有几块油田。。
Problem solving: 简单的DFS。从‘@’开始,把经过的‘@’周围8个方向的‘@’都搜索到,算作一块,最后统计搜索的次数。要想完整的遍历一个区域,可以用dfs,可以在搜索的时候直接把一个区域的所有‘@’都赋值为‘*’,这样,下次再搜索的时候就不会重复了。

#include <stdio.h>
#include <string.h>
char map[110][110];
int r, c, next[8][2] = {{1, 0}, {1, 1}, {1, -1}, {0, -1}, {0, 1}, {-1, 0}, {-1, 1}, {-1, -1}};
void DFS(int x, int y) {
    int tx, ty;
    map[x][y] = '*';
    for (int i = 0; i < 8; i++) {
        tx = x + next[i][0];
        ty = y + next[i][1];
        if (tx < 0 || tx >= r || ty < 0 || ty >= c)
            continue;
        if (map[tx][ty] == '@')
            DFS(tx, ty);
    }
}
int main() {
    while (scanf("%d%d", &r, &c), r || c) {
        int ans = 0;
        for (int i = 0; i < r; i++)
            for (int j = 0; j < c; j++)
                scanf(" %c", &map[i][j]);
        for (int i = 0; i < r; i++) {
            for (int j = 0; j < c; j++) {
                if (map[i][j] == '@') {
                    DFS(i, j);
                    ans++;
                }
            } 
        }
        printf("%d\n", ans);
    }
    return 0;
}