题干:

Josephina is a clever girl and addicted to Machine Learning recently. She 
pays much attention to a method called Linear Discriminant Analysis, which 
has many interesting properties. 
In order to test the algorithm's efficiency, she collects many datasets. 
What's more, each data is divided into two parts: training data and test 
data. She gets the parameters of the model on training data and test the 
model on test data. To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0. 



It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?

Input

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.

Output

For each test case, output the answer in a line. Round to 4 digits after the decimal point.

Sample Input

2
1
2 0 0
2
2 0 0
2 -4 2

Sample Output

0.0000
0.5000

解题报告:

    由于题中给出的a>=0, 所以a有可能为零,(但是这个题好像并没有在这里设坑)此时曲线为直线,否则曲线为开口向上的抛物线,故为下凸函数,所以F(x)也为下凸函数。故可用三分法求F(x)的极值。先算出F(x)的具体值,然后就可直接三分了。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
 
const int MAX = 10000 + 10;
int n, a[MAX], b[MAX], c[MAX];
 
double cal(double x) {                //求F(x)
	double ans = a[0]*x*x + b[0]*x + c[0];
	for(int i=1; i<n; i++) {
		ans = max(ans, a[i]*x*x+b[i]*x+c[i]);
	}
	return ans;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d", &n);
		for(int i=0; i<n; i++) {
			scanf("%d%d%d", &a[i], &b[i], &c[i]);
		}
        double l = 0, r = 1000;           //三分求极值
		for(int i=0; i<100; i++) {
			double mid = l + (r-l)/3;
			double midd = r - (r-l)/3;
			if(cal(mid) < cal(midd))  r = midd;
			else  l = mid;
		}
		printf("%.4f\n",cal(l));
	}
	return 0;
}

总结:

   这里还有一个黑科技!不用定义eps来卡精度!直接卡时间!还有二分次数可以多一点,二分区间为10^6,才二分二十多次,可以二分100次。for循环!不用while(l<r)!!