Description:

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input:

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output:

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input:

5
1 1
5 1
7 1
3 3
5 5

Sample Output:

1
2
1
1
0

题目链接 题目链接

树状数组总结

树状数组根据每个星星的横坐标(因为按照纵坐标升序给出星星坐标,所以计算星星等级时只用统计它左边有多少星星即可)记录等级,不断维护更新。

题目没说但是有多组数据,数组在HDU开32001大小可以过但是在POJ要开32005以上。

树状数组下表从1开始,但x取值可以为0并且若x为0在getLevel函数中会产生死循环,所以x要++。

AC代码:

#pragma comment(linker, "/STACK:102400000,102400000")
//#include <bits/stdc++.h>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define pb push_back
#define mp make_pair
#define lowbit(x) (x&(-x))
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int> PII;
typedef pair<double,double> PDD;
const int INF = 0x3f3f3f3f;
const int maxn = 3e4+2e3+5;
const int mod = 1e9+7;
const double eps = 1e-8;
const double pi = asin(1.0)*2;
const double e = 2.718281828459;
bool Finish_read;
template<class T>inline void read(T &x){Finish_read=0;x=0;int f=1;char ch=getchar();while(!isdigit(ch)){if(ch=='-')f=-1;if(ch==EOF)return;ch=getchar();}while(isdigit(ch))x=x*10+ch-'0',ch=getchar();x*=f;Finish_read=1;}

int n;
// cnt[i]是等级为i的星星数量
int cnt[maxn];
// c[i]是当前i星星的等级
int c[maxn];

// 更新树状数组
void update(int x) {
	while (x < maxn) {
		c[x]++;
		x += lowbit(x);
	}
}

// 获取x星等级
int getLevel(int x) {
	int level = 0;
	while (x > 0) {
		level += c[x];
		x -= lowbit(x);
	}
	return level;
}

int main(int argc, char *argv[]) {
#ifndef ONLINE_JUDGE
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w", stdout);
#endif
	// 多组数据!
	while (scanf("%d", &n) != EOF) {
		mem(cnt, 0);
		mem(c, 0);
		for (int i = 0, x, y; i < n; ++i) {
			// 题目按照升序给出,所以y没用
			read(x); read(y);
			// 树状数组下表从0开始,但x取值可以为0并且若x为0在getLevel函数中会产生死循环,所以x++
			x++;
			cnt[getLevel(x)]++;
			update(x);
		}
		for (int i = 0; i < n; ++i) {
			printf("%d\n", cnt[i]);
		}
	}
#ifndef ONLINE_JUDGE
    fclose(stdin);
    fclose(stdout);
    system("gedit out.txt");
#endif
    return 0;
}