Diophantus of Alexandria
Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat’s last theorem) was found only recently by Andrew Wiles.
Consider the following diophantine equation:
1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)
Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions:
1 / 5 + 1 / 20 = 1 / 4
1 / 6 + 1 / 12 = 1 / 4
1 / 8 + 1 / 8 = 1 / 4
Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?
Input
The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9).
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line.
Sample Input
2
4
1260
Sample Output
Scenario #1:
3
Scenario #2:
113
x1+ y1= n1 => xyy+x= n1 => nx+ny=xy =>(x-n)y=nx => y= x−nnx
设x=n+k,则y= kn(n+k)=n+ kn2
所以关键就是找出 n2的因子个数ans
因为x<=y,如果ans是偶数,那最终结果就是ans/2;如果ans是奇数,那最终结果就是ans/2+1
综上(ans+1)/2就是最终结果
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=4e4;
typedef long long ll;
bool p[maxn];
int prime[maxn],cnt=0;
void isp(){
p[0]=p[1]=true;
for(int i=2;i<maxn;i++){
if(!p[i])
prime[cnt++]=i;
for(int j=0;j<cnt&&(ll)i*prime[j]<maxn;j++){
p[i*prime[j]]=true;
if(i%prime[j]==0) break;
}
}
}
int main(){
isp();
int n,T;
scanf("%d",&T);
for(int k=1;k<=T;k++){
scanf("%d",&n);
ll ans=1,res;
for(int i=0;i<cnt;i++){
if(n==1) break;
res=0;
while(n%prime[i]==0){
res++; //res为prime[i]的指数
n/=prime[i];
}
ans*=2*res+1;//因为求的是n^2的因子个数,所以 ans*=2*res+1
}
if(n!=1) ans*=3; //ans*=2*1+1;
printf("Scenario #%d:\n",k);
printf("%lld\n\n",(ans+1)/2);//因为x<=y,所以要除以2 结果向上取整
}
return 0;
}