题目

一个正整数,如果交换高低位以后和原数相等,那么称这个数为回文数。
比如 <math> <semantics> <mrow> <mn> 121 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 121 </annotation> </semantics> </math>121 <math> <semantics> <mrow> <mn> 2332 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 2332 </annotation> </semantics> </math>2332 都是回文数, <math> <semantics> <mrow> <mn> 13 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 13 </annotation> </semantics> </math>13 <math> <semantics> <mrow> <mn> 4567 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 4567 </annotation> </semantics> </math>4567 不是回文数。
任意一个正整数,如果其不是回文数,将该数交换高低位以后和原数相加得到一个新的数,如果新数不是回文数,重复这个变换,直到得到一个回文数为止。
例如, <math> <semantics> <mrow> <mn> 57 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 57 </annotation> </semantics> </math>57 变换后得到 <math> <semantics> <mrow> <mn> 132 </mn> <mo> ( </mo> <mn> 57 </mn> <mo> + </mo> <mn> 75 </mn> <mo> ) </mo> </mrow> <annotation encoding="application&#47;x&#45;tex"> 132(57 + 75) </annotation> </semantics> </math>132(57+75) <math> <semantics> <mrow> <mn> 132 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 132 </annotation> </semantics> </math>132 得到 <math> <semantics> <mrow> <mn> 363 </mn> <mo> ( </mo> <mn> 132 </mn> <mo> + </mo> <mn> 231 </mn> <mo> ) </mo> </mrow> <annotation encoding="application&#47;x&#45;tex"> 363(132 + 231) </annotation> </semantics> </math>363(132+231) <math> <semantics> <mrow> <mn> 363 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 363 </annotation> </semantics> </math>363 是一个回文数。
曾经有数学家猜想:对于任意正整数,经过有限次上述变换以后,一定能得出一个回文数。
至今这个猜想还没有被证明是对的。
现在请你通过程序来验证。

输入格式
输入一行一个正整数 <math> <semantics> <mrow> <mi> n </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> n </annotation> </semantics> </math>n

输出格式
输出第一行一个正整数,表示得到一个回文数的最少变换次数。
接下来一行,输出变换过程,相邻的数之间用"—>"连接。
输出格式可以参见样例。
保证最后生成的数在 int 范围内。

样例输入

349

样例输出

3

349—>1292—>4213—>7337

题解

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
// 判断是否为回文数 
bool isHui(int n){
	string str;
	// 得到该数的逆转字符串 
	while(n){
		str += n%10;
		n /= 10;
	}
	string ReStr = str;
	// 将逆转字符转回去 
	reverse(ReStr.begin(),ReStr.end());
	if(ReStr == str)
		return true;
	else
		return false;
}
int main(){
	int n;
	vector<int> v;
	int num = 0; 
	cin>>n;
	v.push_back(n);
	while(!isHui(n)){  // 当它不是回文数 
		int re = 0;
		int tmp = n;
		// 用 re 存其各位变换后的数 
		while(tmp){
			re = tmp%10 + re*10; 
			tmp /= 10;
		}
		n += re;
		num++;
		v.push_back(n);
	}
	cout<<num<<endl;
	for(int i=0;i<v.size();i++)
		if(i!=0)
			cout<<"--->"<<v[i];
		else
			cout<<v[i];
	return 0;
}

返回目录,查看更多