活动选择

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

学校的大学生艺术中心周日将面向全校各个学院的学生社团开放,但活动中心同时只能供一个社团活动使用,并且每一个社团活动开始后都不能中断。现在各个社团都提交了他们使用该中心的活动计划(即活动的开始时刻和截止时刻)。请设计一个算法来找到一个最佳的分配序列,以能够在大学生艺术中心安排不冲突的尽可能多的社团活动。
比如有5个活动,开始与截止时刻分别为:



最佳安排序列为:1,4,5。

Input

第一行输入活动数目n(0<n<100);
以后输入n行,分别输入序号为1到n的活动使用中心的开始时刻a与截止时刻b(a,b为整数且0<=a,b<24,a,b输入以空格分隔)。

Output

输出最佳安排序列所包含的各个活动(按照活动被安排的次序,两个活动之间用逗号分隔)。

Example Input

6
8 10
9 16
11 16
14 15
10 14
7 11

Example Output

1,5,4

Hint

Author

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
struct node
{
    int i,a,b;


}c[101];


int cmp( const void*a,const void*b)
{
   struct node*c = (node*)a;
   struct node*d = (node*)b;

  return c->b - d->b;
}
int main()
{

  int n;
  scanf("%d",&n);
  for(int i=1;i<=n;i++)
  {
        scanf("%d%d",&c[i].a,&c[i].b);
        c[i].i = i;
  }
  qsort(c,n,sizeof(c[1]),cmp);
int   k = 1;
  printf("%d",c[1].i);
  for(int m=2;m<=n;m++)
  {
      if(c[m].a>=c[k].b)
      {
         printf(",%d",c[m].i);
         k = m;
      }

  }
  printf("\n");


  return 0;

}


/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 108KB
Submit time: 2017-01-11 20:57:01
****************************************************/