E - Birthday Paradox
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

Output

For each case, print the case number and the desired result.

Sample Input

2

365

669

Sample Output

Case 1: 22

Case 2: 30

一道大水题。。。。

乍一看是Paradox我还有点慌

然后发现。。。。。

期望与概率都和动态规划联系好大呀,看样子得花点时间去看看背包啦;

毕竟菜,没办法。。。

这题就是不断连乘直到s小于0.5为止。。。

本来我还以为会超时。。。

然后发现ac啦。。。

感觉有了自己的风格啦。。。

#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
#define debug(x) cout<<#x<<'='<<x<<endl;
#define ya(x) scanf("%d",&x)
#define Cas(x) printf("Case %d: ",x)
#define wen(x) printf("%d\n",x)
#define FOR(T) for(int cas=1;cas<=T;cas++)
int main()
{
    int T;
    ya(T);
    FOR(T)
    {
        int n;
        ya(n);
        double s=1;
        int i=n;
        int t=0;
        while(s>0.5){
            s=s*(i-1)/n;
            i--;
            t++;
        }
        Cas(cas);
    printf("%d\n",t);
    }
    return 0;
}