题目内容如下:
Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.
The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:
S1, S2, ..., S13,
H1, H2, ..., H13,
C1, C2, ..., C13,
D1, D2, ..., D13,
J1, J2
where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.
Sample Input:
2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
Sample Output:
S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5
输出的思路是根据每张花色13张,最后两张小丑,1-12的都好判断,除法和取模就行了。但是13、26、39、52这种就需要多一步考虑。我自己想到的输出很直观,就是通过条件判断:
/* A1042 Shuffling Machine */
#include <cstdio>
const int N = 54;
char mark[5] = {'S', 'H', 'C', 'D', 'J'};
int order[N+1] = {0}, startc[N+1] = {0}, endc[N+1] = {0};
int main()
{
int n;
scanf("%d", &n);
for (int i = 1; i <= N; i++) {
startc[i] = i;
}
for (int i = 1; i <= N; i++) {
scanf("%d", &order[i]);
}
for (int cir = 1; cir <= n; cir++) {
for (int i = 1; i <= N; i++) {
endc[order[i]] = startc[i];
}
for (int i = 1; i <= N; i++) {
startc[i] = endc[i];
}
}
for (int i = 1; i <= N; i++) {
if (endc[i] % 13 == 0){
printf("%c%d", mark[endc[i] / 13 - 1], 13);
}
else {
printf("%c%d", mark[endc[i] / 13], endc[i] % 13);
}
if (i != N){
printf(" ");
}
}
return 0;
}
但绝对是有更好的输出的,就比如下面这个,问题出在取模上,那么就先减去1避免13整数倍数字出现,然后再加回去。并且这个空格的处理也很是精妙。
for(int i = 1; i <= N; i++){
if(i != 1) printf(" ");
start[i]--;
printf("%c%d", mark[startc[i] / 13], startc[i] % 13 + 1);
}