Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input


5 10 
1 2 3 4 5 
5 4 3 2 1

Sample Output

14

题目大意:

输入一个数a,表示有a组测试数据,输入b和c分别表示骨头重量和背包容量,数组m存骨头价值,数组w存骨头重量,求最大价值。

C++

#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
int main()
{
    int m[1005],n[1005],w[1005];
    int a,b,c,d,e,f;
    cin>>a;
    while(a--)
    {
        cin>>b>>c;
        for(int i=0;i<b;i++)
            cin>>m[i];
        for(int i=0;i<b;i++)
            cin>>w[i];
        memset(n,0,sizeof(n));
        for(int i=0;i<b;i++)
        {
            for(d=c;d>=w[i];d--)
            {
                n[d]=max(n[d],n[d-w[i]]+m[i]);
            }
        }
        cout<<n[c]<<endl;
    }
    return 0;
}