Conscription

Time Limit: 1000MS Memory Limit: 65536K

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

思路:

因为一个男生和一个女生配,所以的话,要是最小的话就是最小生成树的kruscal算法,然后再并查集的时候就将女生的下标记为i+n以免和男生冲突(种族并查集的思维),最后得出答案就好了。

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
typedef long long ll;
const int maxn = 10010;
const int maxm = 50010;
struct Edge {
    int from;
    int to;
    int dis;
    bool friend operator < (Edge a, Edge b) {
        return a.dis > b.dis;
    }
};
Edge edge[maxm];
int father[maxn << 1];
int FindFather(int x) {
    int a = x;
    while (x != father[x]) x = father[x];
    while (a != father[a]) {
        int z = a;
        a = father[a];
        father[z] = x;
    }
    return x;
}
void UnionFather(int a, int b) {
    int fa = FindFather(a);
    int fb = FindFather(b);
    if (fa != fb) father[fa] = fb;
}
int main() {
    ios::sync_with_stdio(false);
    int t, n, m, r;
    scanf("%d", &t);
    while (t--) {
        scanf("%d %d %d", &n, &m, &r);
        for (int i = 0; i < n + m; i++) father[i] = i;
        for (int i = 0; i < r; i++) {
            scanf("%d %d %d", &edge[i].from, &edge[i].to, &edge[i].dis);
            edge[i].to += n;
        }
        sort(edge, edge + r);
        int ans = 0;
        for (int i = 0; i < r; i++) {
            if (FindFather(edge[i].from) != FindFather(edge[i].to)) {
                UnionFather(edge[i].from, edge[i].to);
                ans += edge[i].dis;
            }
        }
        printf("%d\n", (n + m) * 10000 - ans);
    }
    return 0;
}