Roads in the North
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6281 Accepted: 2950

Description

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice.
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area.

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1.
Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.
Output

You are to output a single integer: the road distance between the two most remote villages in the area.
Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7
Sample Output

22

一个简单的树的直径,通常采用两次 bfs 来求,当然也可以树形dp ,第一次 bfs 找到离当前点的最远的点,然后在用刚刚找到的点,再 bfs 一次,找到离这个点最远的点,这两个点的距离就是树的直径。

AC代码:

#pragma GCC optimize(2)
#include<queue>
#include<iostream>
#define int long long
using namespace std;
const int N=2e4+10;
int head[N],nex[N],to[N],w[N],tot,st;
inline void add(int a,int b,int c){
	to[++tot]=b; w[tot]=c; nex[tot]=head[a]; head[a]=tot;
}
int bfs(int x){
	queue<int> q;	int vis[N]={0};	q.push(x);	vis[x]=1;
	int d[N]={0};	int dis=0;	
	while(q.size()){
		int u=q.front();	q.pop();
		for(int i=head[u];i;i=nex[i]){
			if(vis[to[i]])	continue;
			d[to[i]]=d[u]+w[i];	q.push(to[i]);	vis[to[i]]=1;
			if(d[to[i]]>dis)	dis=d[to[i]],st=to[i];
		}
	}
	return dis;
}
signed main(){
	int a,b,c;
	while(cin>>a>>b>>c)	add(a,b,c),add(b,a,c);
	bfs(1);	cout<<bfs(st)<<endl;
	return 0;
}