Description

相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。

Input

输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。

Output

每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.

Sample Input

2
2
10 10
20 20
3
1 1
2 2
1000 1000

Sample Output

1414.2
oh!

///@zhangxiaoyu
///2015/8/7
///浮点数,prime应用,简单题

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<ctype.h>
#include<iostream>
#define maxn 105
#define INF 9999999999
using namespace std;

struct node{
   int pos1,pos2;
};

struct node a[maxn];
double Map[maxn][maxn];
double dis[maxn];
bool vis[maxn];

double solve(node x,node y)
{
    return sqrt((y.pos2-x.pos2)*(y.pos2-x.pos2)+(y.pos1-x.pos1)*(y.pos1-x.pos1));
}

void prime(int n)
{
    dis[1]=0.0;
    for(int i=0;i<n;i++)
    {
        int mark;
        double minn=INF;
        for(int j=0;j<n;j++)
        {
            if(!vis[j]&&dis[j]<minn)
            {
                minn=dis[j];
                mark=j;
            }
        }
        vis[mark]=true;
        for(int j=0;j<n;j++)
        {
            if(!vis[j]&&Map[mark][j]<dis[j])
                dis[j]=Map[mark][j];
        }
    }
}

int main()
{
    int tt;
    scanf("%d",&tt);
    while(tt--)
    {
       memset(vis,false,sizeof(vis));
       for(int i=0;i<maxn;i++)
        dis[i]=INF;
       for(int i=0;i<maxn;i++)
       {
           for(int j=0;j<maxn;j++)
           {
               Map[i][j]=INF;
           }
       }
       int n,x,y,k=0;
       scanf("%d",&n);
       for(int i=0;i<n;i++)
       {
           scanf("%d%d",&x,&y);
           a[k].pos1=x;
           a[k].pos2=y;
           k++;
       }
       for(int i=0;i<k;i++)
       {
           for(int j=i+1;j<k;j++)
           {
               if(solve(a[i],a[j])>=10&&solve(a[i],a[j])<=1000)
                  Map[i][j]=Map[j][i]=solve(a[i],a[j]);
           }
       }
       prime(n);
       double ans=0.0;
       for(int i=0;i<n;i++)
        ans+=dis[i];
       ans*=100;
       if(ans<INF)
        printf("%.1lf\n",ans);
       else
        printf("oh!\n");
    }
    return 0;
}