Description
对于给出的n个询问,每次求有多少个数对(x,y),满足a≤x≤b,c≤y≤d,且gcd(x,y) = k,gcd(x,y)函数为x和y的最大公约数。
Input
第一行一个整数n,接下来n行每行五个整数,分别表示a、b、c、d、k
Output
共n行,每行一个整数表示满足要求的数对(x,y)的个数
Sample Input
2
2 5 1 5 1
1 5 1 5 2
2 5 1 5 1
1 5 1 5 2
Sample Output
14
3
HINT
100%的数据满足:1≤n≤50000,1≤a≤b≤50000,1≤c≤d≤50000,1≤k≤50000
解法:http://blog.csdn.net/just_sort/article/details/54866354 套上一个容斥
///BZOJ 2301
///Mobius
#include <bits/stdc++.h>
using namespace std;
const int maxn = 50005;
int n, a, b, c, d, k;
int tot, mu[maxn], pri[maxn];
int sum[maxn];
bool mark[maxn];
void getMobius(){
mu[1]=1;
tot=0;
memset(mark, 0, sizeof(mark));
for(int i=2; i<=50000; i++){
if(!mark[i]) pri[++tot]=i, mu[i]=-1;
for(int j=1; j<=tot&&i*pri[j]<=50000; j++){
mark[i*pri[j]]=1;
if(i%pri[j]==0){
mu[i*pri[j]]=0;
break;
}
else{
mu[i*pri[j]]=-mu[i];
}
}
}
sum[0]=0LL;
for(int i=1; i<=50000; i++) sum[i]=sum[i-1]+mu[i];
}
int f(int a, int b, int D){
a/=D, b/=D;
int x = min(a, b), pos;
int ans=0LL;
for(int d=1; d<=x; d=pos+1){
pos=min(a/(a/d), b/(b/d));
ans+=(sum[pos]-sum[d-1])*(a/d)*(b/d);
}
return ans;
}
int main()
{
getMobius();
scanf("%d", &n);
while(n--){
scanf("%d%d%d%d%d", &a,&b,&c,&d,&k);
int ans = f(b,d,k)-f(a-1,d,k)-f(b,c-1,k)+f(a-1,c-1,k);
printf("%d\n", ans);
}
return 0;
}