Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17829    Accepted Submission(s): 6482


 

Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

 

Sample Input
 
5 1 1 5 1 7 1 3 3 5 5
 

 

Sample Output
 
1 2 1 1 0
 

 

Source
 
题意:给出 n 个星星的坐标,每颗星星的等级等于横纵坐标均 <= 它的星星数。问不同等级的星星分别有多少颗。
 
标准的二位偏序问题。刚刚学完CDQ来练练手。
 
CDQ学习:
 
#include<bits/stdc++.h>
using namespace std;
const int N = 15005;
const int inf = 0x3f3f3f3f;

int cnt[N], ans[N];

struct node {
    int x, y, id;
}s[N], tmp[N];    //tmp储存归并结果

void CDQ(int l, int r) {
    if(l == r) return ;
    int mid = (l + r) / 2;
    CDQ(l, mid);
    CDQ(mid + 1, r);
    //递归后当前区间[l, r]已经按照横坐标排好序了
    int t1 = l;            //左区间起始位置
    int t2 = mid + 1;      //右区间起始位置
    for(int i = l; i <= r; ++i) {    //按横坐标排序
        if((t1 <= mid && s[t1].x <= s[t2].x) || t2 > r) {   ///判断条件为第一关键字
            tmp[i] = s[t1++];
        }
        else {
            ans[s[t2].id] += t1 - l;    //左区间影响右区间的逆序对
            tmp[i] = s[t2++];
        }
    }
    for(int i = l; i <= r; ++i)
        s[i] = tmp[i];
}

int main(){
    int n;
    while(~scanf("%d", &n)) {
        memset(s, 0, sizeof(s));
        for(int i = 0; i < n; ++i) cnt[i] = 0;
        for(int i = 1; i <= n; ++i) ans[i] = 0;
        for(int i = 1; i <= n; ++i) {
            scanf("%d%d", &s[i].x, &s[i].y);
            s[i].id = i;
        }
        CDQ(1, n);
        for(int i = 1; i <= n; ++i)
            cnt[ans[i]]++;
        for(int i = 0; i < n; ++i)
            printf("%d\n", cnt[i]);
    }
    return 0;
}