Apple Catching

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

题意:有两棵苹果树,编号为1,2.在t时间内,每秒钟其中一棵苹果树会掉下1个苹果。现要去接苹果,在t时间内最多走动w次,问在满足条件下最多能接到苹果的个数。
dp :f [ i ][ j ]代表在第i分钟,移动第j次时 能吃到的最多苹果(当前在哪颗苹果树下,是可以通过 j 得到)
       如果此分钟当前苹果树不掉苹果 :f [ i ][ j ]=max( f [ i-1 ][ j ], f [ i-1 ][ j-1 ])

      否则:f [ i ][ j ]=max( f [ i-1 ][ j ], f [ i-1 ][ j-1 ] )+1



#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;

long t,w;
long a[1020];
long f[1020][40];
void dp()
{
    if(a[1] == 1)
    {
        f[1][0] = 1;
        f[1][1] = 0;
    }
    if(a[1] == 2)
    {
        f[1][0] = 0;
        f[1][1] = 1;
    }
    for(long i = 2; i <= t; i++)
    {
        for(long j = 0; j <= w; j++)
	{
            f[i][j] = max(f[i - 1][j -1 ], f[i - 1][j]);
            if ((a[i] - 1) == (j % 2))
            f[i][j]++;
	}
   }
}
int main()
{
    scanf("%d%d", &t, &w);
    for(long i = 1; i <= t ; i++)
    {
	scanf("%d", &a[i]);
    }
    dp();

    long maxn = f[t][0];
    for(long i = 1; i <= w; i++)
	if(f[t][i] > maxn)
            maxn = f[t][i];
    printf("%d", maxn);

    return 0;
}