A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

思路:如果俩点没有相连 , 看一下他们的父节点是否相同 , 若不相同就将他们相连 , 若相同则表明存在环。

这题输入有些不方便 , 因为0 0的时候是当前输入结束 ,-1 -1是整体结束

我这里用了俩个while循环 , emmm.......可能不太好吧

还有就是要记下他有多少颗树,父节点不同则有多少颗树

代码:

#include <stdio.h>
using namespace std;

const int maxn = 100050;
int father[maxn] , vis[maxn] ,flag;
void init()
{
	for(int i = 1 ; i <= maxn ; i++)
	{
		father[i] = i;
		vis[i] = 0;
	}
}
int getf(int x)
{
	return x == father[x] ? x : father[x] = getf(father[x]);
}
void merge(int x , int y)
{
	vis[x] = 1;
	vis[y] = 1;
	int fx = getf(x);
	int fy = getf(y);
	if(fx != fy)
	{
		father[fx] = fy;
	}
	else
	{
		flag = 1;//说明有环 
	}
}
int main()
{
	int a , b , num = 0 , flag , p;
	while(1)
	{
		flag = 0 , p = 0;
		init();
		scanf("%d %d" , &a , &b);
		if(a == -1 && b == -1)
		{
			break;
		}
		if(a == 0 && b == 0)
		{
			printf("Case %d is a tree.\n" , ++num);
			continue;
		}
		merge(a , b);
		while(1)
		{
			scanf("%d %d" , &a , &b);
			if(a == 0 && b == 0)
			{
				break;
			}
			merge(a , b);
		}
		for(int i = 1 ; i <= maxn ; i++)
		{
			if(vis[i] == 1)
			{
				if(i == father[i])
				{
					p++;
			//		printf(" p = %d\n" , p); 
				}
			}
		}
		if(flag == 0 && p == 1)
		{
			printf("Case %d is a tree.\n" , ++num);
		}
		else
		{
			printf("Case %d is not a tree.\n",++num);
		}
	}
	return 0;
}