Arctic Network

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

题意描述:

求出最小生成树中第s大的路径.

解题思路:

求出各点间的距离存入map数组,再求出最小生成树dis数组,从大到小排序,输出第s大的数。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
# define inf 0x7f7f7f7f
using namespace std; 
int a[600],b[600],book[600];
double map[600][600],dis[600];
double cmp(double x,double y)
{
	return x>y;
}
int main()
{
	int n,m,t,i,j,u,v;
	double min;
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%d%d",&m,&n);
			for(i=1;i<=n;i++)
				scanf("%d%d",&a[i],&b[i]);
			memset(map,0,sizeof(map));
			for(i=1;i<n;i++)
				for(j=i+1;j<=n;j++)
				{
					map[i][j]=(double)(sqrt((a[i]-a[j])*(a[i]-a[j])+(b[i]-b[j])*(b[i]-b[j])));
					map[j][i]=map[i][j];
				}
			memset(book,0,sizeof(book));
			for(i=1;i<=n;i++)
				dis[i]=map[1][i];
			book[1]=1;
			for(i=1;i<n;i++)
			{
				min=inf;
				for(j=1;j<=n;j++)
				{
					if(book[j]==0&&dis[j]<min)
					{
						min=dis[j];
						u=j;
					}
				}
				book[u]=1;
				for(v=1;v<=n;v++)
				{
					if(book[v]==0&&dis[v]>map[u][v])
						dis[v]=map[u][v];
				}
			}
			sort(dis+1,dis+n+1,cmp);
			printf("%.2f\n",dis[m]);
		}
	}
	return 0;
}