Description:

The Olympic Games in Bercouver are in full swing now. Here everyone has their own objectives: sportsmen compete for medals, and sport commentators compete for more convenient positions to give a running commentary. Today the main sport events take place at three round stadiums, and the commentator’s objective is to choose the best point of observation, that is to say the point from where all the three stadiums can be observed. As all the sport competitions are of the same importance, the stadiums should be observed at the same angle. If the number of points meeting the conditions is more than one, the point with the maximum angle of observation is prefered.

Would you, please, help the famous Berland commentator G. Berniev to find the best point of observation. It should be noted, that the stadiums do not hide each other, the commentator can easily see one stadium through the other.

Input:

The input data consists of three lines, each of them describes the position of one stadium. The lines have the format x,  y,  r, where (x, y) are the coordinates of the stadium’s center (  1 0 3 x , y 1 0 3 -  10^{3} ≤ x,  y ≤ 10^{3} 103x,y103 ), and r ( 1 r 1 0 3 1 ≤ r  ≤ 10^{3} 1r103 ) is its radius. All the numbers in the input data are integer, stadiums do not have common points, and their centers are not on the same line.

Output:

Print the coordinates of the required point with five digits after the decimal point. If there is no answer meeting the conditions, the program shouldn’t print anything. The output data should be left blank.

Sample Input:

0 0 10
60 0 10
30 30 10

Sample Output:

30.00000 0.00000

题目连接

题目可以用退火算法不断接近最优结果,模拟退火算法
这道题目先确定一个点,求出三个视角的误差值,然后不断更新这个点的坐标,减小误差值,以确定最终答案。(此题还可以推出求解公式)。

AC代码:

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <iomanip>
#include <cctype>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <cstdlib>
#include <sstream>
#include <set>
#include <map>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define pb push_back
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int> P;
const int INF = 0x3f3f3f3f;
const int maxn = 1e5+5;
const double eps = 1e-5;
const double pi = asin(1.0)*2;
const double e = 2.718281828459;
void fre() {
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w", stdout);
}

struct circle {
    double x, y, r;
}c[3];
double ansx, ansy;
double err;
double angle[3];
double step;
int dx[4] = {-1, 0, 1, 0}, dy[4] = {0, -1, 0, 1};

double cal_dis(circle a, circle b) {
    return sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y));
}

double cal_err(circle a) {
    for (int i = 0; i < 3; ++i) {
        angle[i] = cal_dis(a, c[i]) / c[i].r;
    }
    double err = 0;
    for (int i = 0; i < 3; ++i) {
        err += (angle[i] - angle[(i + 1) % 3]) * (angle[i] - angle[(i + 1) % 3]);
    }
    return err;
}

int main() {
    //fre();
    ansx = 0; ansy = 0;
    for (int i = 0; i < 3; ++i) {
        scanf("%lf%lf%lf", &c[i].x, &c[i].y, &c[i].r);
        ansx += c[i].x;
        ansy += c[i].y;
    }
    ansx /= 3; ansy /= 3;
    err = cal_err((circle){ansx, ansy, 0});
    step = 1;

    for (int t = 1; t <= maxn; ++t) {
        bool tag = 0;
        double x, y;
        for (int i = 0; i < 4; ++i) {
            double nx = ansx + dx[i] * step;
            double ny = ansy + dy[i] * step;
            double error = cal_err((circle{nx, ny, 0}));
            if (error < err) {
                err = error;
                x = nx;
                y = ny;
                tag = 1;
            }
        }
        if (!tag) {
            step /= 2;
        }
        else {
            ansx = x;
            ansy = y;
        }
    }

    if (err < eps) {
        printf("%0.5lf %0.5lf", ansx, ansy);
    }
    return 0;
}