You are given a positive integer n, please count how many positive integers k satisfy k^k≤n.
Input
There are no more than 50 test cases.
Each case only contains a positivse integer n in a line.
1≤n≤10181≤n≤1018
Output
For each test case, output an integer indicates the number of positive integers k satisfy k^k≤n in a line.
Sample Input
1
4
Sample Output
1
2
注意提前算一下在long long 范围内k的最大值,防止k^k超long lon***生错误
#include<cstdio>
using namespace std;
typedef long long ll;
ll ksm(ll a,ll b){
ll s=1;
while(b){
if(b&1) s*=a;
a*=a;
b>>=1;
}
return s;
}
int main(){
ll n;
// while(~scanf("%lld",&n)){
// printf("%lld\n",ksm(n,n)); 测试k的最大值
// }
while(~scanf("%lld",&n)){
int ans=0;
for(int i=1;i<=15&&ksm(i,i)<=n;i++){
ans++;
}
printf("%d\n",ans);
}
return 0;
}