题目来源:

http://acm.hdu.edu.cn/showproblem.php?pid=5546

Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go. 

Here is the rules for ancient go they were playing: 

⋅⋅The game is played on a 8×88×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×99×9 different positions to put the chess. 
⋅⋅Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately. 
⋅⋅The chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board. 
⋅⋅When one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components. 
One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's chess.

Input

The first line of the input gives the number of test cases, T(1≤T≤100)T(1≤T≤100). TT test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. ′.′′.′ represents an empty cell. ′x′′x′ represents a cell with black chess which owned by Yu Zhou. ′o′′o′ represents a cell with white chess which owned by Su Lu.

Output

For each test case, output one line containing Case #x: y, where xx is the test case number (starting from 1) and yy is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu's components. Can not kill in one move!!! otherwise.

Sample Input

2

.......xo
.........
.........
..x......
.xox....x
.o.o...xo
..o......
.....xxxo
....xooo.

......ox.
.......o.
...o.....
..o.o....
...o.....
.........
.......o.
...x.....
........o

Sample Output

Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!

        
  

Hint

In the first test case, Yu Zhou has 4 different ways to kill Su Lu's component.

In the second test case, there is no way to kill Su Lu's component.

题目意思:下围棋,就是黑子先下,看下一个子可以围死白子的棋子吗,下棋前的死子不算。

直接搜索每一个白棋,看是否除了白棋有没有一个空白的棋格,有的话就可以围死。

段错误是什么锅,迷。。。

思路:dfs实现

参考代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
const double PI = acos(-1.0);
const double eps = 1e-6;
const int INF = 0x3f3f3f3f;
char a[20][20];
int mv[4][2]= {0,1,1,0,0,-1,-1,0};
int vis[15][15], cnt;
void dfs(int x, int y)
{
    if(a[x][y] == '.'){
        cnt ++;
        return ;
    }
    for(int i = 0; i<4; i++)
    {
        int xx = x + mv[i][0];
        int yy = y + mv[i][1];
        if(a[xx][yy] != 'x' && !vis[xx][yy] && xx>=1 && xx<=9 && yy>=1 && yy<=9)
        {
            vis[xx][yy] = 1;
            dfs(xx, yy);
        }
    }
}
int main()
{
    int t;
    cin>>t;
    for(int cas = 1; cas<=t; cas++)
    {
        for(int i = 0; i<=10; i++)
        {
            a[0][i] = 'x';
            a[i][0] = 'x';
            a[10][i] = 'x';
            a[i][10] = 'x';
        }
        for(int i = 1; i<=9; i++)
            for(int j = 1; j<=9; j++)
               cin>>a[i][j];
        bool falg  = 0;
        for(int i = 1; i<=9; i++)
        {
            for(int j = 1; j<=9; j++)
            {
                if(a[i][j] == 'o')
                {
                    memset(vis, 0, sizeof(vis));
                    cnt = 0;
                    dfs(i, j);
                   // cout<<cnt<<endl;
                    if(cnt == 1)
                    {
                        falg = 1;
                        break;
                    }
                }
            }
            if(falg) break;
        }
        if(falg) printf("Case #%d: Can kill in one move!!!\n", cas);
        else printf("Case #%d: Can not kill in one move!!!\n", cas);
    }
    return 0;
}