题干:

The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output. 

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, 
and 1 being the lowest), and the printer operates as follows.

  • The first job J in queue is taken from the queue.
  • If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.
  • Otherwise, print job J (and do not put it back in the queue).

In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life. 

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input

One line with a positive integer: the number of test cases (at most 100). Then for each test case:

  • One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
  • One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

 

Output

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

Sample Input

3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1

Sample Output

1
2
5

题目大意:

一个打印序列,有优先级别顺序。从前往后扫描,若该作业优先级别已是最高,则执行此作业。若不是,放到队列末尾。求指定位置的作业mine被执行的时间。

解题报告:

       用一个队列和优先队列来模拟整个过程就可以了,刚开始非要只用优先队列然后找个规律就可以了,结果发现有很多特殊情况需要考虑,最后放弃了这一种做法。

AC代码:

#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
int n,vip,mine,res;
int main() {
	int t;
	scanf("%d",&t);
	while (t--) {
		queue<int> q;
		priority_queue<int> pq;
		scanf("%d%d",&n,&mine);mine++;
		for (int i = 0; i < n; ++i) {
			scanf("%d",&vip);
			q.push(vip);
			pq.push(vip);
		}
		res = mine;
		while (1) {
			int cur = q.front();q.pop();
			if (res == 1) {//如果打印的是当前任务 
				if (cur != pq.top()) {//还有优先级更高的。
					q.push(cur);
					res = pq.size();
				} 
				else break;
			} 
			else {
				res--;
				if (cur != pq.top()) {
					q.push(cur);
				}
				else pq.pop();
			}
		}
		printf("%d\n", n-q.size());
	}

	return 0;
}

错误代码:

#include<bits/stdc++.h>
#define ll long long
using namespace std;
const int MAX = 1e2 + 5 ;
int n,mine,myvip,myid;
int bk[15];
struct Node {
	int id,vip;
	Node(){}
	Node(int id,int vip):id(id),vip(vip){}
	bool operator < (const Node b) const{
		if(vip != b.vip) return vip < b.vip;
		return id > b.id;
	}
} node[MAX];
int main()
{
	int t;
	cin>>t;
	while(t--) {
		priority_queue<Node> pq;
		cin>>n>>mine;mine++;
		for(int i = 1; i<=n; i++) {
			scanf("%d",&node[i].vip);node[i].id=i;
			pq.push(node[i]);
			bk[node[i].vip]++;
			if(i==mine) myvip = node[i].vip,myid = bk[myvip]-1;//myid记录前面有几个 
		} 
		
		int ans = 0,tmp = 0;
		for(int i = 1; i<=n; i++) {
			if(pq.top().vip == myvip) break;
			pq.pop();
			ans++;
		}
		printf("ans = %d\n",ans);
		for(int i = n; i>=1; i--) {
			if(node[i].vip > myvip) break;
			if(node[i].vip == myvip) tmp++;
		}
		printf("tmp = %d\n",tmp);
//		while(!pq.empty()) {
//			if(pq.top().id == mine) break;
////			pq.pop();
//			tmp++;
//		}
		printf("%d\n",ans + myid + tmp + 1);
	}
	
	return 0 ;
}