Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
提示:数组是1000000以上;
C++版本一
BFS
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <cstring>
#include <queue>
using namespace std;
int a[10000010];
long n,k;
struct node
{
long x;
long cnt;
}front1,tmp,start;
queue <node> Q;
long bfs(node s){
while(!Q.empty())
Q.pop();
if(s.x==k)return s.cnt;
Q.push(s);
while(!Q.empty()){
front1=Q.front();
Q.pop();
for(int i=-1;i<=1;i++){
if(i==0)
tmp.x=2*front1.x;
else
tmp.x=front1.x+i;
if(tmp.x>=0&&tmp.x<=1000000&&a[tmp.x]==0){
a[tmp.x]=1;
tmp.cnt=front1.cnt+1;
//printf("%ld \n",tmp.x);
Q.push(tmp);
}
if(tmp.x==k) return tmp.cnt;
}
}
return -1;
}
int main()
{
while(~scanf("%ld%ld",&n,&k)){
getchar();
memset(a,0,sizeof(a));
a[n]=1;
//ans=0;
start.x=n;
start.cnt=0;
printf("%ld\n",bfs(start));
}
//cout << "Hello world!" << endl;
return 0;
}
C++版本二
BFS
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
const int N = 1000000;
int map[N+10];
int n,k;
struct node
{
int x,step;
};
int check(int x)
{
if(x<0 || x>=N || map[x])
return 0;
return 1;
}
int bfs(int x)
{
int i;
queue<node> Q;
node a,next;
a.x = x;
a.step = 0;
map[x] = 1;
Q.push(a);
while(!Q.empty())
{
a = Q.front();
Q.pop();
if(a.x == k)
return a.step;
next = a;
//每次都将三种状况加入队列之中
next.x = a.x+1;
if(check(next.x))
{
next.step = a.step+1;
map[next.x] = 1;
Q.push(next);
}
next.x = a.x-1;
if(check(next.x))
{
next.step = a.step+1;
map[next.x] = 1;
Q.push(next);
}
next.x = a.x*2;
if(check(next.x))
{
next.step = a.step+1;
map[next.x] = 1;
Q.push(next);
}
}
return -1;
}
int main()
{
int ans;
while(~scanf("%d%d",&n,&k))
{
memset(map,0,sizeof(map));
ans = bfs(n);
printf("%d\n",ans);
}
return 0;
}