Description
韩信点兵。韩信在点兵的时候,为了知道有多少个兵,同时又能保住军事机密,便让士兵排队报数。
(1)按从1到5报数,记下最后一个士兵报的数为a
(2) 再按从1到6报数,记下最后一个士兵的报数为b
(3)再按从1到7报数,记下最后一个士兵的报数为c
(4)再按从1到11报数,记下最后一个士兵的报数为d
计算韩信至少有多少兵?
Input
首先输入一个整数T表示有T组测试数据,然后对于每组测试数据。对于每组测试数据,输入4个整数,分别是a b c d
Output
对于每组测试数据,请输出一行,为韩信至少有的兵数
Sample Input
1
1 5 4 10
Sample Output
2111
#include <stdio.h>
#include <stdlib.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int main(int argc, char *argv[]) {
int n;
while(scanf("%d",&n)!=EOF)
{
int t;
for(t=1;t<=n;t++)
{
int a,b,c,d;
scanf("%d%d%d%d",&a,&b,&c,&d);
int i;
for(i=1;i<=10000;i++)
{
if(i%5==a&&i%6==b&&i%7==c&&i%11==d)
{
printf("%d\n",i);
break;
}
}
}
}
return 0;
}