Farmer John's farm consists of a long row of N (1 <= N <= 100,000)fields. Each field contains a certain number of cows, 1 <= ncows <= 2000.
FJ wants to build a fence around a contiguous group of these fields in order to maximize the average number of cows per field within that block. The block must contain at least F (1 <= F <= N) fields, where F given as input.
Calculate the fence placement that maximizes the average, given the constraint.
Input
* Line 1: Two space-separated integers, N and F.
* Lines 2..N+1: Each line contains a single integer, the number of cows in a field. Line 2 gives the number of cows in field 1,line 3 gives the number in field 2, and so on.
Output
* Line 1: A single integer that is 1000 times the maximal average.Do not perform rounding, just print the integer that is 1000*ncows/nfields.
Sample Input
10 6 6 4 2 10 3 8 5 9 4 1
Sample Output
6500
#include <iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
#define INF 0x3f3f3f3f
int n,f;
double a[100000+100],b[100000+100];
double sum[100000+100];
bool sloved(double mid){
double ans = -INF;
double minl = INF;
for(int i=1; i <= n; i++)
b[i] = a[i] - mid;
for(int i = 1; i <= n; i++)
sum[i] = sum[i-1] + b[i];
for(int i = f; i <= n; i++){
minl = min(minl, sum[i-f]);
ans = max(ans, sum[i]-minl);
}
if(ans>=0) return 1;
return 0;
}
int main()
{
scanf("%d%d",&n,&f);
sum[0]=0;
double maxl=0;
for(int i=1;i<=n;i++){
scanf("%lf",&a[i]);
maxl=max(maxl,a[i]);
}
double l=0;
double r=maxl;
double mid;
while(r-l>0.0000001){
mid=(l+r)/2;
if(sloved(mid)){
l=mid;
}else{
r=mid;
}
}
cout <<(int)(1000*(r+0.000001))<< endl;
//cout << "Hello world!" << endl;
return 0;
}