Description
由n个1组成的整数能被K(K<10000)整除,n至少为多少?
Input
多组测试数据,第一行输入整数T,表示组数 然后是T行,每行输入1个整数代表K
Output
对于每组测试数据输出1行,值为n
Sample Input
1
11
Sample Output
2
#include <stdio.h>
#include <stdlib.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int main(int argc, char *argv[]) {
int t;
while(scanf("%d",&t)!=EOF){
int i;
for(i=1;i<=t;i++){
int k;
scanf("%d",&k);
if(k==1){
printf("%d\n",1);
continue;
}
unsigned long n=1;
int c=1;
int temp=1;
while(temp!=0){
temp=temp*10+1;
temp=temp%k;
c++;
}
printf("%d\n",c);
}
}
return 0;
}