前言
正文
This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2… NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK
<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6
思路:
分别将两个多项式的系数记录在数组a和数组b中,再通过一个二重循环将结果存到数组c中,最后输出数组c中的非零元素即可
参考题解:
#include<cstdio>
const int max_len=1010;
double a[max_len],b[max_len],c[2*max_len+1];
int main(){
int k,m,count=0;
double n;
scanf("%d",&k);
while(k--){
scanf("%d%lf",&m,&n);
a[m]+=n;
}
scanf("%d",&k);
while(k--){
scanf("%d%lf",&m,&n);
b[m]+=n;
}
for(int i=0;i<max_len;i++){
if(a[i]!=0){
for(int j=0;j<max_len;j++){
if(b[j]!=0){
c[i+j]+=a[i]*b[j];
}
}
}
}
for(int i=0;i<2*max_len+1;i++){
if(c[i]!=0)count++;
}
printf("%d",count);
for(int i=2*max_len;i>=0;i--){
if(c[i]!=0)printf(" %d %.1f",i,c[i]);
}
return 0;
}
后记
最近回味许嵩的歌曲,我还是那个我