https://vjudge.net/contest/66965#problem/A


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9

A 2 B 12 I 25

B 3 C 10 H 40 I 8

C 2 D 18 G 55

D 1 E 44

E 2 F 60 G 38

F 0

G 1 H 35

H 1 I 35

3

A 2 B 10 C 40

B 1 C 20

0

Sample Output

216

30

思路:

这是一道最小生成树的问题,我们可以用kruskal算法来写,即运用并查集的思想解决,我们先将所有的边存入结构体数组中,要存入起始点终点和权重,然后我们将结构体按权重从小到大排序,遍历所有边,如果这条边的两点的父节点不同,则合并成一个点,并把权重加入和中,否则则已合并成一个点,跳过,。遍历完所有的边后,输出和即可。

代码

#include <iostream>

#include <cstdio>

#include <fstream>

#include <algorithm>

#include <cmath>

#include <deque>

#include <vector>

#include <queue>

#include <string>

#include <cstring>

#include <map>

#include <stack>

#include <set>

using namespace std;

int father[100001];

struct node{//创建结构体

       char u,v;

       int c;

}x[100005];

bool cmp(node a,node b)//重构排序方法

{

       return a.c<b.c;//以权重从小到大排序

}

int fin(int t)//查集

{

    if(father[t]!=t)

    father[t]=fin(father[t]);

    return father[t];

}

void unionn(int r1,int r2)//并集

{

    father[r2]=r1;

}

int main()

{

       int n,m;

       scanf("%d\n",&n);

       do{

              if(n==0)

              return 0;

              int m=1;

              memset(father,0,sizeof(father));

              scanf("\n");

              for(int i=1;i<=n-1;i++)

              {

                     char y;

                     scanf("%c ",&y);

                     int k;

                     scanf("%d ",&k);

                     if(k==0)//当这个点无连接时跳过

                     {

                            scanf("\n");

                            continue;

                     }

                     for(int j=1;j<=k;j++)

                     {

                            x[m].u=y;//将起点输入

                            char p;

                            if(j!=k)

                            scanf("%c %d ",&x[m].v,&x[m].c);//将终点和权重输入

                            else

                            scanf("%c %d\n",&x[m].v,&x[m].c);

                            m++;//记录边数

                      }

              }

              m--;

              sort(x+1,x+m+1,cmp);//把边排序

              for(int i=1;i<=n;i++)

              {

                     father[i]=i;//初始化父节点

              }

              int ans=0;//用于记录和

              for(int i=1;i<=m;i++)

              {

                     int a=fin(x[i].u-'A'+1);

                     int b=fin(x[i].v-'A'+1);

                     if(a!=b)//判断是否已经联通

                     {

                            ans+=x[i].c;//加上

                            unionn(a,b);//并集

                     }

              }

              cout<<ans<<endl;//输出

       }while(scanf("\n%d",&n));

}