Description
输入一个十进制数N,将它转换成R进制数输出。
Input
输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)。
Output
为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。
Sample Input
7 2
23 12
-4 3
Sample Output
111
1B
-11

#include <stdio.h>
#include <stdlib.h>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main(int argc, char *argv[]) {
	long n,r;
	while(scanf("%d %d",&n,&r)!=EOF&&r>=2&&r!=10&&r<=16)
	{
		int i=0,j,k;
		long a[31];
		//正负数标记 
		if(n>=0)
		k=1;
		else
		k=-1;
		//转换 
		while(n!=0){
			a[i]=abs(n%r);
			n/=r;
			i++;
		}
		//负数负号输出 
		if(k==-1)
		printf("-");
		//输出 
		for(j=i-1;j>=0;j--){
			
			if(a[j]>9){
				
				switch (a[j])
					{
					case 10:printf("A");break;
					case 11:printf("B");break;
					case 12:printf("C");break;
					case 13:printf("D");break;
					case 14:printf("E");break;
					case 15:printf("F");break;
					
					}
			}
			else{
					printf("%d",a[j]);				
			}
		}
		
		printf("\n");
	}
	return 0;
}