http://acm.hdu.edu.cn/showproblem.php?pid=1489

Problem Description

As you may know from the comic "Asterix and the Chieftain's Shield", Gergovia consists of one street, and every inhabitant of the city is a wine salesman. You wonder how this economy works? Simple enough: everyone buys wine from other inhabitants of the city. Every day each inhabitant decides how much wine he wants to buy or sell. Interestingly, demand and supply is always the same, so that each inhabitant gets what he wants.

There is one problem, however: Transporting wine from one house to another results in work. Since all wines are equally good, the inhabitants of Gergovia don't care which persons they are doing trade with, they are only interested in selling or buying a specific amount of wine. They are clever enough to figure out a way of trading so that the overall amount of work needed for transports is minimized.

In this problem you are asked to reconstruct the trading during one day in Gergovia. For simplicity we will assume that the houses are built along a straight line with equal distance between adjacent houses. Transporting one bottle of wine from one house to an adjacent house results in one unit of work.

 

 

Input

The input consists of several test cases.
Each test case starts with the number of inhabitants n (2 ≤ n ≤ 100000). The following line contains n integers ai (-1000 ≤ ai ≤ 1000). If ai ≥ 0, it means that the inhabitant living in the ith house wants to buy ai bottles of wine, otherwise if ai < 0, he wants to sell -ai bottles of wine. You may assume that the numbers ai sum up to 0.
The last test case is followed by a line containing 0.

 

 

Output

For each test case print the minimum amount of work units needed so that every inhabitant has his demand fulfilled. You may assume that this number fits into a signed 64-bit integer (in GCC/G++ you can use the data type "long long", in JAVA the data type "long", in VC/VC++ will be "__int64". More information about data type on HDOJ, please view F.A.Q.).

 

 

Sample Input


 

5 5 -4 1 -3 1 6 -1000 -1000 -1000 1000 1000 1000 0

 

 

Sample Output


 

9 9000

 

 

Source

2006/2007 ACM-ICPC University of Ulm Local Contest

 

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1488 1490 1483 1484 1915 

题解:

从1开始,假设有一个送货的工作人员,按顺序发东西,他拿着东西或者欠着走,每次加上所携带的绝对值

/*
*@Author:   STZG
*@Language: C++
*/
#include <bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<string>
#include<vector>
#include<bitset>
#include<queue>
#include<deque>
#include<stack>
#include<cmath>
#include<list>
#include<map>
#include<set>
//#define DEBUG

using namespace std;
typedef long long ll;
const int N=10000;
const double PI = acos(-1.0);
const double EXP = 1E-8;
const int INF = 0x3f3f3f3f;
ll t,n,m;

int main()
{
#ifdef DEBUG
	freopen("input.in", "r", stdin);
	//freopen("output.out", "w", stdout);
#endif
    while(~scanf("%lld",&n)&&n){
        ll tmp=0;
        ll ans=0;
        for(int i=1;i<=n;i++){
            scanf("%lld",&t);
            tmp+=t;
            ans+=abs(tmp);
        }
        cout << ans << endl;
    }

    //cout << "Hello world!" << endl;
    return 0;
}