某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。 
当N为0时,输入结束,该用例不被处理。 

Output

对每个测试用例,在1行里输出最小的公路总长度。 

Sample Input

krusal算法裸题

krusal算法是基于“避圈法”的思想,避圈法可以用并查集实现。

krusal又是基于贪心思想的。

先把所有边按从小到大的顺序排序。然后,逐个选取,在选取的过程中,如果查询到两个端点不在同一个集合,那么必然选择它作为最小生成树的一部分,并合并这两个端点。

如果查询到这两个端点在同一个集合里,那么继续选取下一条边,直至选取了n-1条边,算法结束。

算法复杂度为排序的复杂度。O(e*log(e))

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output

3
5


        
  
Huge input, scanf is recommended.

Hint

Hint
        
 
#include <iostream>
#include <stdio.h>
#include <string.h>
#include<algorithm>

using namespace std;
const int N=10000+10;
#define INF 0x3f3f3f
int n,m,pre[N];
struct node{
    int f,t,l;
    node(){};
    node(int a,int b,int c){
        f=a;
        t=b;
        l=c;
    }
    bool operator <(const node &S)const{
        return l<S.l;

    }
}edge[N];
int find(int x){
    int r=x;
    while(pre[r]!=r){
        r=pre[r];
    }
    return r;
}
void join(int x,int y){
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
        pre[fy]=fx;
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n){
        int a,b,c;
        m=(n*(n-1))/2;
        for(int i=1;i<=m;i++){
            scanf("%d%d%d",&a,&b,&c);
            edge[i]=node(a,b,c);
        }
        sort(edge+1,edge+m+1);
        for(int i=1;i<=n;i++){
            pre[i]=i;
        }
        int ans=0;
        for(int i=1;i<=m;i++)
            if(find(edge[i].f)!=find(edge[i].t)){
                join(edge[i].f,edge[i].t);
                ans+=edge[i].l;
            }

        cout << ans << endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}