http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3211

JAVAMAN is visiting Dream City and he sees a yard of gold coin trees. There are ntrees in the yard. Let's call them tree 1, tree 2 ...and tree n. At the first day, each tree i has ai coins on it (i=1, 2, 3...n). Surprisingly, each tree i can grow bi new coins each day if it is not cut down. From the first day, JAVAMAN can choose to cut down one tree each day to get all the coins on it. Since he can stay in the Dream City for at most m days, he can cut down at most m trees in all and if he decides not to cut one day, he cannot cut any trees later. (In other words, he can only cut down trees for consecutive m or less days from the first day!)

Given nmai and bi (i=1, 2, 3...n), calculate the maximum number of gold coins JAVAMAN can get.

 

 

Input

 

There are multiple test cases. The first line of input contains an integer T (T <= 200) indicates the number of test cases. Then T test cases follow.

Each test case contains 3 lines: The first line of each test case contains 2 positive integers n and m (0 < m <= n <= 250) separated by a space. The second line of each test case contains n positive integers separated by a space, indicating ai. (0 < ai <= 100, i=1, 2, 3...n) The third line of each test case also contains npositive integers separated by a space, indicating bi. (0 < bi <= 100, i=1, 2, 3...n)

 

Output

 

For each test case, output the result in a single line.

 

Sample Input

 

 

2
2 1
10 10
1 1
2 2
8 10
2 3

 

 

Sample Output

 

 

10
21

 

 

Hint

s:
Test case 1: JAVAMAN just cut tree 1 to get 10 gold coins at the first day.
Test case 2: JAVAMAN cut tree 1 at the first day and tree 2 at the second day to get 8 + 10 + 3 = 21 gold coins in all.

/*
*@Author:   STZG
*@Language: C++
*/
#include <bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<string>
#include<vector>
#include<bitset>
#include<queue>
#include<deque>
#include<stack>
#include<cmath>
#include<list>
#include<map>
#include<set>
//#define DEBUG

using namespace std;
typedef long long ll;
const int N=256;
const double PI = acos(-1.0);
const double EXP = 1E-8;
const int INF = 0x3f3f3f3f;
int t,n,m;
struct node{
    int a,b;
    bool operator <(const node &S)const{
        return b<S.b;
    }
}e[N];
int dp[N];
int main()
{
#ifdef DEBUG
	freopen("input.in", "r", stdin);
	//freopen("output.out", "w", stdout);
#endif
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        for(int i=0;i<=m;i++)
                dp[i]=-INF;
        dp[0]=0;
        for(int i=1;i<=n;i++)
            scanf("%d",&e[i].a);
        for(int i=1;i<=n;i++)
            scanf("%d",&e[i].b);
        sort(e+1,e+n+1);
        for(int i=1;i<=n;i++){
            for(int j=m;j>=1;j--){
                if(dp[j-1]!=-INF){
                   dp[j]=max(dp[j],dp[j-1]+(j-1)*e[i].b+e[i].a);
                }
            }
        }
        cout << dp[m] << endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}