Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.
Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
Sample Output
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
C++版本一
#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int N=10000000+10;
int n,pre[N],ranksize[N];
int find(int x){
int r=x;
while(pre[r]!=r)
r=pre[r];
return r;
}
void join(int x,int y){
int fx=find(x);
int fy=find(y);
if(fx!=fy){
if(ranksize[fx]>=ranksize[fy]){
pre[fy]=fx;
ranksize[fx]+=ranksize[fy];
}else{
pre[fx]=fy;
ranksize[fy]+=ranksize[fx];
}
}
}
int main()
{
while(scanf("%d",&n)!=EOF){
if(n==0){
cout << 1 << endl;
continue;
}
for(int i=1;i<N;i++){
pre[i]=i;
ranksize[i]=1;
}
int a,b;
int m=0;
for(int i=1;i<=n;i++){
scanf("%d%d",&a,&b);
m=max(m,max(a,b));
join(a,b);
}
int maxn=1;
for(int i=1;i<=m;i++){
maxn=max(maxn,ranksize[i]);
}
cout << maxn << endl;
}
//cout << "Hello world!" << endl;
return 0;
}
C++版本二
只需用一个rank记录每个节点下面有多少个人,并在合并的时候累加给上一级
需要注意当n==0时,输出为1
#include <stdio.h>
struct Node{
int pre;
int rank;
}tree[10000005];
int maxn;
int Find(int x){
int p = x;
while(tree[p].pre != p){
p = tree[p].pre;
}
int i = x;
while(i != p){
int j = tree[i].pre;
tree[i].pre = p;
i = j;
}
return p;
}
void Join(int x,int y){
int fx = Find(x);
int fy = Find(y);
if(fx != fy){
tree[fy].rank += tree[fx].rank;
if(tree[fy].rank > maxn){
maxn = tree[fy].rank;
}
tree[fx].pre = fy;
}
}
int main(){
int n;
int i,j;
int x,y;
while(scanf("%d",&n) != EOF){
maxn = 1;
for(i = 0;i < 10000005;i++){
tree[i].pre = i;
tree[i].rank = 1;
}
for(i = 0;i < n;i++){
scanf("%d%d",&x,&y);
Join(x,y);
}
printf("%d\n",maxn);
}
return 0;
}