题目描述

  为了用事实说明挖掘机技术到底哪家强,PAT 组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:

  输入在第 1 行给出不超过 10的5次方的正整数 N,即参赛人数。随后 N 行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从 1 开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:

  在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。

输入样例:

6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例:

2 150

代码

package com.hbut.pat;
import java.io.*;

public class Pat_1032 {
    public static void main(String[] args) throws IOException {
        StreamTokenizer st = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
        st.nextToken();
        int n = (int) st.nval,max = 0,len,sch = 0;
        int[] score = new int[n];
        while(0 < n--) {
        	st.nextToken();
            int schoo = (int) st.nval;
            st.nextToken();
            int sco = (int) st.nval;
            score[schoo] += sco;
        }

        len = score.length;
        for(int i = 1 ; i < len ; i++) {
            if(score[i] > max) {
                max = score[i];
                sch = i;
            }
        }
        System.out.print(sch + " " + max);
    }
}