Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

题意:给出一个数n,然后求得一个数字k,数字满足:能被n整除,每一位只有0,1。这样的数字k会有很多个,然以输出一个就可以。

思路:n的最大值为200,用dfs从数字k的个位开始往高位搜索,每一位只有0或1。找到能被n整除的时候输出就可以了。

ps:(一开始不知道到底应该搜到多少位时可以return,后来看到网上说最多到19位就可以)

C++

DFS

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
long n;
int a[200];
int flag;
void dfs(int c,long long k){
    if(flag||c>=19)return;
    if(k%n==0){
        printf("%lld\n",k);
        flag=1;
        return;
    }
    dfs(c+1,k*10);
    dfs(c+1,k*10+1);

}


int main()
{
    while(scanf("%ld",&n)!=EOF){
        if(n==0) break;
        flag=0;
        dfs(0,1);
    }
   // cout << "Hello world!" << endl;
    return 0;
}