FJ’s N (1 ≤ N ≤ 10,000) cows conveniently indexed 1…N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.

FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form “cow 17 sees cow 34”. This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

For each cow from 1…N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

Input
Line 1: Four space-separated integers: N, I, H and R
Lines 2… R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.
Output
Lines 1… N: Line i contains the maximum possible height of cow i.
Sample Input
9 3 5 5
1 3
5 3
4 3
3 7
9 8
Sample Output
5
4
5
3
4
4
5
5
5
a能看到b b大于等于a 那么b和a都相等就行了,中间的牛每头牛减一就可。
差分数组就形成了。最后求个前缀和,转化为和第一头牛的差值就行了
想了一想发现 第一头牛无论怎么样都可以达到h,然后h+查分的前缀和就能求出每头牛的高度了

#include<stdio.h>
#include<algorithm>
#include<map>
using namespace std;
map<pair<int,int>,bool>ex;
int d[10005];
int a[10005];
int main()
{
   
	int n,m,h,r;
	scanf("%d%d%d%d",&n,&m,&h,&r);
	while(r--)
	{
   
		int a,b;
		scanf("%d%d",&a,&b);
		if(a>=b)
		{
   
			swap(a,b);
		}
		if(ex[make_pair(a,b)]==1)//避免重复
		continue;
		ex[make_pair(a,b)]=1;
		d[a+1]--;d[b]++;
	}
	for(int i=1;i<=n;i++)
	printf("d[%d]=%d\n",i,d[i]);
	for(int i=1;i<=n;i++)
	{
   
		d[i]=d[i]+d[i-1];
		printf("d[%d]=%d\n",i,d[i]);
		a[i]=h+d[i];
		printf("a[%d]=%d\n",i,a[i]);
	}

 }