While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

C++版本一

Bellman_Ford

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include<set>
#include<vector>
#include<map>
#define MAXV 1010
#define INF 0x3f3f3f3f
#define MAXM 2710
using namespace std;

struct{
	int x,y,t;
}edge[MAXM];

int n,m,w;

int bellman_ford(){
	int i,j,d[MAXV],flag=1,cnt=1;
	for(i=1;i<=n;i++)
        d[i]=INF;

	while(flag){
		flag=0;
		if(cnt++>n) return 1;
		for(i=1;i<=m;i++){
			if(d[edge[i].x]+edge[i].t<d[edge[i].y])
                {d[edge[i].y]=d[edge[i].x]+edge[i].t;flag=1;}
			if(d[edge[i].y]+edge[i].t<d[edge[i].x])
                {d[edge[i].x]=d[edge[i].y]+edge[i].t;flag=1;}
		}
		for(;i<=m+w;i++)
			if(d[edge[i].y]>d[edge[i].x]-edge[i].t)
                {d[edge[i].y]=d[edge[i].x]-edge[i].t;flag=1;}
	}
	return 0;
}

int main(){
	int t,i;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d%d",&n,&m,&w);
		for(i=1;i<=m+w;i++)
			scanf("%d%d%d",&edge[i].x,&edge[i].y,&edge[i].t);
		if(bellman_ford())
            printf("YES\n");
		else
            printf("NO\n");
	}
	return 0;
}

C++版本二

SPFA

#include<stdio.h>
#include<string.h>
#include<queue>
#define MAXN 5200
using namespace std;
struct node
{
    int to,next,val;
}edge[MAXN];
int cnt,n,m,w;
int head[MAXN],visit[MAXN],dis[MAXN],hash[MAXN];
void init()
{
    memset(head,-1,sizeof(head));
    memset(hash,0,sizeof(hash));
    cnt=1;
}
void addedge(int from,int to,int val)
{
    edge[cnt].to=to;
    edge[cnt].val=val;
    edge[cnt].next=head[from];
    head[from]=cnt++;
}
int spfa()
{
    memset(dis,0x3f,sizeof(dis));
    memset(visit,0,sizeof(visit));
    dis[1]=0;
    visit[1]=1;
    queue<int>q;
    q.push(1);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        visit[u]=0;
        hash[u]++;
        if(hash[u]>m)
        {
            return 1;
        }
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].to;
            if(dis[u]+edge[i].val<dis[v])
            {
                dis[v]=dis[u]+edge[i].val;
                if(!visit[v])
                {
                    visit[v]=1;
                    q.push(v);
                }
            }
        }
    }
    return 0;
}
int main()
{
    int f;
    scanf("%d",&f);
    while(f--)
    {
        init();
        scanf("%d%d%d",&n,&m,&w);
        for(int i=1;i<=m;i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            addedge(a,b,c);
            addedge(b,a,c);
        }
        for(int i=1;i<=w;i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            addedge(a,b,-c);
        }
        if(spfa())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}