Problem Description:
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input:
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output:
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input:
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output:
45
59
6
13
思路:本题是简单的深搜bfs模板
MY DaiMa:
#include<iostream>
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int n,m,t;
char flag[21][21];
struct point
{
int x,y;
}start;
int bfs()
{
queue<point>Q;
point cur,next;
flag[start.x][start.y]='#';
Q.push(start);
while(!Q.empty())
{
cur=Q.front();
Q.pop();
for(int i=0;i<4;i++)
{
next.x=cur.x+dir[i][0];
next.y=cur.y+dir[i][1];
if((next.x>=0&&next.x<n)&&(next.y>=0&&next.y<m)&&flag[next.x][next.y]=='.')
{
t++;
flag[next.x][next.y]='#';
Q.push(next);
}
}
}
return t;
}
int main()
{
while(cin>>m>>n&&(n!=0&&m!=0))
{
t=1;
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
cin >> flag[i][j];
if(flag[i][j]=='@')
{
start.x=i;
start.y=j;
}
}
}
//t = bfs();
cout << bfs() <<endl;
}
return 0;
}