A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 295229 Accepted Submission(s): 56839
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
大整数加法:字符数组接收,逆序成整形,然后进位相加,前导去掉,再逆序输出
#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int main(){
int T;
char a[1005],b[1005];
int x[1005],y[1005];
int ans[1005];
scanf("%d",&T);
for(int k=1;k<=T;k++){
memset(x,0,sizeof(x));
memset(y,0,sizeof(y));
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(ans,0,sizeof(ans));
scanf("%s %s",a,b);
int len1=strlen(a);
int len2=strlen(b);
for(int i=0;i<len1;i++)
x[i]=a[len1-1-i]-'0';
for(int i=0;i<len2;i++)
y[i]=b[len2-1-i]-'0'; //逆序两数
int c=0; //代表进位
for(int i=0;i<len1+1||i<len2+1;i++){
ans[i]=(x[i]+y[i]+c)%10;
c=(x[i]+y[i]+c)/10;
} //两者之和可能比原来的位数多1
printf("Case %d:\n",k);
printf("%s + %s = ",a,b);
int len=len1 > len2? len1 :len2;
for(int i=len; i>=0;i--){
if(i==len&&ans[i]==0)
continue;
else
{
printf("%d",ans[i]);
}
}
printf("\n");
if(k!=T)
printf("\n");
}
return 0;
}