省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
Output
对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。
Sample Input
3 3 1 2 1 1 3 2 2 3 4 1 3 2 3 2 0 100
Sample Output
3 ?
#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int N=10000+10;
int m,n,pre[N];
struct node{
int f,t,l;
node (){};
node (int a ,int b ,int c){
f=a;
t=b;
l=c;
}
bool operator <(const node &S)const{
return l<S.l;
}
}e[N];
int find(int x){
int r=x;
while(pre[r]!=r)
r=pre[r];
return r;
}
void join(int x,int y){
int fx=find(x);
int fy=find(y);
if(fx!=fy)
pre[fx]=fy;
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF&&n){
int a,b,c;
for(int i=1;i<=n;i++){
scanf("%d%d%d",&a,&b,&c);
e[i]=node(a,b,c);
}
sort(e+1,e+n+1);
for(int i=1;i<=m;i++)
pre[i]=i;
int ans=0;
for(int i=1;i<=n;i++)
if(find(e[i].f)!=find(e[i].t)){
join(e[i].f,e[i].t);
ans+=e[i].l;
}
int cnt=0;
for(int i=1;i<=m;i++)
if(pre[i]==i)
cnt++;
if(cnt-1==0)
cout << ans << endl;
else
cout << "?" << endl;
}
//cout << "Hello world!" << endl;
return 0;
}