http://acm.hdu.edu.cn/contests/contest_showproblem.php?pid=1001&cid=832
Problem Description
“上一个国家的人真的是好心呢。”
在山脉群之间,是一片宽广平坦的大地。被草木覆盖的绿意,顺着灰色的山间延伸。
摩托车(注:两轮的车子,尤其是指不在天空飞行的交通工具)飞驰在道路上。
骑士年约十五、六岁,有着一头黑色短发及炯炯有神的脸庞。
她身穿黑色夹克,腰际系着一条粗皮带。右腿悬挂着左***式的掌中说服者(注:说服者是枪械。这里是指***)的枪袋。她腰际后面还挂着另一把自动式说服者。
"奇诺,听说只要n个连续时刻的速度都严格大于零,摩托车就能飞向月球上面诶”
身为摩托车的艾鲁梅斯这么兴奋是因为在上个国家改装了引擎。
之前拜访的国家盛产自动驾驶车辆,其中“文远知行”公司是其中的佼佼者,在自动驾驶领域是数一数二的存在。
“那家公司的工程师给你改装了引擎吧,听说能一直驾驶飞到月球?”
“如果奇诺你一直加大油门啦,听说能加速到11.2km/s呢。”
“一般的摩托车承受不了吧,再说他们刚好把你的仪表盘换成了电子表盘,我不是很习惯。”
“没关系啦,只要一点点勇气,什么都做得成。”
艾鲁梅斯说完,奇诺索性就把油门踩到底,顿时摩托车如同违背了其本身的定义一样,在紫红色的天空下朝着月亮画出了航迹云。
现在给出一个n,表示在n个连续的时刻下艾鲁梅斯的速度。
如果艾鲁梅斯能飞往月球就输出“WeRide.ai”,否则输出“Transform Mobility With Autonomous Driving”
Input
第一行输入一个整数T(T<=10),代表有T组样例
对于每组样例:
第一行输入一个整数n,(1<=n<=100),代表n个连续时刻的速度。
第二行输入n个整数ai(0<=ai<=100),代表该时刻艾鲁梅斯的速度。
Output
对于每组样例:
如果艾鲁梅斯能飞往月球就输出“WeRide.ai”(没有引号);
否则输出“Transform Mobility With Autonomous Driving”(没有引号)。
Sample Input
2 5 1 2 3 4 5 5 1 2 3 4 0
Sample Output
WeRide.ai Transform Mobility With Autonomous Driving
/*
*@Author: STZG
*@Language: C++
*/
#include <bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<string>
#include<vector>
#include<bitset>
#include<queue>
#include<deque>
#include<stack>
#include<cmath>
#include<list>
#include<map>
#include<set>
//#define DEBUG
using namespace std;
typedef long long ll;
const int N=10000;
const double PI = acos(-1.0);
const double EXP = 1E-8;
const int INF = 0x3f3f3f3f;
int t,n,m;
int a[N];
int main()
{
#ifdef DEBUG
freopen("input.in", "r", stdin);
//freopen("output.out", "w", stdout);
#endif
scanf("%d",&t);
while(t--){
scanf("%d",&n);
for(int i=1;i<=n;i++){
scanf("%d",&a[i]);
}
int flag=1;
for(int i=1;i<=n;i++){
if(a[i]==0)
flag=0;
}
if(flag)
cout<<"WeRide.ai"<<endl;
else
cout<<"Transform Mobility With Autonomous Driving"<<endl;
}
//cout << "Hello world!" << endl;
return 0;
}