http://acm.hdu.edu.cn/showproblem.php?pid=2066
Problem Description 虽然草儿是个路痴(就是在杭电待了一年多,居然还会在校园里迷路的人,汗~),但是草儿仍然很喜欢旅行,因为在旅途中 会遇见很多人(白马王子,^0^),很多事,还能丰富自己的阅历,还可以看美丽的风景……草儿想去很多地方,她想要去东京铁塔看夜景,去威尼斯看电影,去阳明山上看海芋,去纽约纯粹看雪景,去巴黎喝咖啡写信,去北京探望孟姜女……眼看寒假就快到了,这么一大段时间,可不能浪费啊,一定要给自己好好的放个假,可是也不能荒废了训练啊,所以草儿决定在要在最短的时间去一个自己想去的地方!因为草儿的家在一个小镇上,没有火车经过,所以她只能去邻近的城市坐火车(好可怜啊~)。
Input 输入数据有多组,每组的第一行是三个整数T,S和D,表示有T条路,和草儿家相邻的城市的有S个,草儿想去的地方有D个;
Output 输出草儿能去某个喜欢的城市的最短时间。
Sample Input 6 2 3 1 3 5 1 4 7 2 8 12 3 8 4 4 9 12 9 10 2 1 2 8 9 10
Sample Output 9
Author Grass
Source
Recommend lcy
|
/*
*@Author: STZG
*@Language: C++
*/
#include <bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<string>
#include<vector>
#include<bitset>
#include<queue>
#include<deque>
#include<stack>
#include<cmath>
#include<list>
#include<map>
#include<set>
//#define DEBUG
using namespace std;
typedef long long ll;
const int N=1000+10;
const double PI = acos(-1.0);
const double EXP = 1E-8;
const ll INF = 0x3f3f3f3f3f3f;
int t,s,d,n,m;
int S[N],D[N];
struct node{
int e;
ll w;
};
struct cmp{
bool operator()(const node &a,const node &b){
return a.w>b.w;
}
};
bool BS(int x){
int l=1;
int r=d;
int mid;
while(l<=r){
mid=(l+r)>>1;
if(D[mid]==x) return 1;
else if(D[mid]<x) l=mid+1;
else r=mid-1;
}
return 0;
}
int main()
{
#ifdef DEBUG
freopen("input.in", "r", stdin);
//freopen("output.out", "w", stdout);
#endif
while(scanf("%d%d%d",&t,&s,&d)!=EOF){
priority_queue<node,vector<node>,cmp>que;
vector<node>v[1001];
node x;
int a,b,c;
for(int i=1;i<=t;i++ ){
scanf("%d%d%d",&a,&b,&c);
x.e=b,x.w=c;
v[a].push_back(x);
x.e=a;
v[b].push_back(x);
}
for(int i=1;i<=s;i++ ){
scanf("%d",&S[i]);
}
for(int i=1;i<=d;i++ ){
scanf("%d",&D[i]);
}
sort(D+1,D+d+1);
ll ans=INF;
for(int k=1;k<=s;k++ ){
while(!que.empty())
que.pop();
int vis[1001]={0};
x.e=S[k],x.w=0;
que.push(x);
while(!que.empty()){
x=que.top();
que.pop();
vis[x.e]=1;
if(BS(x.e)){
ans=min(ans,x.w);
break;
}
for(int i=0,j=v[x.e].size(); i<j; i++){
node q;
q.e=v[x.e][i].e;
if(vis[q.e])
continue;
q.w=x.w+v[x.e][i].w;
que.push(q);
}
}
}
cout << ans << endl;
}
//cout << "Hello world!" << endl;
return 0;
}