Description
求阶乘,采用递归的方法,你会写吗?
Input
多组测试数据,首先输入整数T表示组数 然后每一组在一行输入一个整数n( 1 <= n <= 10)
Output
对于每组数据输出一行,值为n的阶乘
Sample Input
1
2
Sample Output
2
HINT
使用递归函数求n!
int fact(int n)
{
}

#include <stdio.h>
#include <stdlib.h>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int fact(int n)
{
	if(n==1)return 1;
	else return n*fact(n-1);
}
int main(int argc, char *argv[]) {	
	int n;
	while(scanf("%d",&n)!=EOF){
		int i;
		for(i=1;i<=n;i++){
			int t;
			scanf("%d",&t);
			printf("%d\n",fact(t));
		}
	}
	return 0;
}