They say that in Phrygia, the streets are paved with gold. You’re currently on vacation in Phrygia, and to your astonishment you discover that this is to be taken literally: small heaps of gold are distributed throughout the city. On a certain day, the Phrygians even allow all the tourists to collect as much gold as they can in a limited rectangular area. As it happens, this day is tomorrow, and you decide to become filthy rich on this day. All the other tourists decided the same however, so it’s going to get crowded. Thus, you only have one chance to cross the field. What is the best way to do so? 

Given a rectangular map and amounts of gold on every field, determine the maximum amount of gold you can collect when starting in the upper left corner of the map and moving to the adjacent field in the east, south, or south-east in each step, until you end up in the lower right corner. 

Input

The input starts with a line containing a single integer, the number of test cases. 
Each test case starts with a line, containing the two integers r and c, separated by a space (1 <= r, c <= 1000). This line is followed by r rows, each containing c many integers, separated by a space. These integers tell you how much gold is on each field. The amount of gold never negative. 
The maximum amount of gold will always fit in an int.

Output

For each test case, write a line containing “Scenario #i:”, where i is the number of the test case, followed by a line containing the maximum amount of gold you can collect in this test case. Finish each test case with an empty line. 

Sample Input

1
3 4
1 10 8 8
0 0 1 8
0 27 0 4

Sample Output

Scenario #1:
42

C++版本一

贪心算法+数塔+DP

对于坐标(i,j)的点,到达他所能得到的最大金子数为:他左边和上边格子中最大那一个的值加上他自己的值。{ map[i][j] += max( map[i-1][j] , map[i][j-1]) }

  为什么能够这样想呢,难道不会有数塔那种情况吗?

 这里跟数塔不同,这里(i,j)的值一定为(能到达他的)以前所有格子最大的值,这样一直递推到最后一个格子就行了。

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;
int t;
int r,c;
int a[1100][1100];

int main()
{
    scanf("%d",&t);
    for(int T=1;T<=t;T++){
        scanf("%d%d",&r,&c);
        memset(a,0,sizeof(a));
        for(int i=1;i<=r;i++){
            for(int j=1;j<=c;j++){
                scanf("%d",&a[i][j]);
                a[i][j] += max(a[i-1][j],a[i][j-1]);
            }
        }
        printf("Scenario #%d:\n",T);
        cout << a[r][c]<< endl<< endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}