There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
Sample Output
2 1 3
题意是:将木棍放在机器里处理,第一根需要一分钟,剩余的如果大于等于前边放入的长度和重量,就不用费时间,否则需要一分钟,计算给出一组数的最少时间!用贪心算出最少降序序列个数!
C++版本一
贪心算法
先排序---后选择第一个没有用过的木头一次向后找,用掉所有可以用掉的木头,然后返回第一个没用过的木头继续找
#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
int n,t;
int a[5100],b[5100];
int vis[5100];
int main()
{
scanf("%d",&t);
while(t--){
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d%d",&a[i],&b[i]);
memset(vis,0,sizeof(vis));
int k;
for(int i=0;i<n;i++){
k=i;
for(int j=i+1;j<n;j++){
if(a[k]>a[j]||(a[k]==a[j]&&b[k]>b[j]))
k=j;
}
if(k!=i){
long temp;
temp=a[k];
a[k]=a[i];
a[i]=temp;
temp=b[k];
b[k]=b[i];
b[i]=temp;
}
}
// for(int i=0;i<n;i++)
// printf("%d %d\n",a[i],b[i]);
int ans=0;
for(int i=0;i<n;i++){
if(vis[i]==0){
ans++;
vis[i]=1;
int nowl=a[i];
int noww=b[i];
for(int j=i+1;j<n;j++){
if(vis[j]==0&&nowl<=a[j]&&noww<=b[j]){
nowl=a[j];
noww=b[j];
vis[j]=1;
// cout << a[j]<<b[j] << endl;
}
}
}
}
cout << ans << endl;
}
//cout << "Hello world!" << endl;
return 0;
}
C++版本二
DP
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define MAX 5000+10
struct node{
int l,w;
}num[MAX];
bool cmp(node a,node b)
{
if(a.l==b.l)
return a.w<b.w;
return a.l<b.l;
}
int dp[MAX];
int a[MAX];
int main()
{
int t,n,i,j,sum;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d%d",&num[i].l,&num[i].w);
}
sort(num+1,num+1+n,cmp);
dp[1]=0;
sum=0;
for(i=1;i<=n;i++)
{
a[i]=num[i].w;
for(j=1;j<=sum;j++)
if(dp[j]<=a[i])
{
dp[j]=a[i];
break;
}
if(j>sum)
dp[++sum]=a[i];
}
printf("%d\n",sum);
}
return 0;
}
C++版本三
#include <iostream>
#include <algorithm>
using namespace std;
#define N 5005
int num[N];
struct stick_node{
int l,w;
};
stick_node stick[N];
bool cmpt(int a,int b){
return a>b;
}
bool cmpl(stick_node a,stick_node b){
if (a.l<b.l)
return true;
return false;
}
int main(){
#ifndef ONLINE_JUDGE
freopen("1051in.txt","r",stdin);
#endif
int t,n,i,j,k;
scanf("%d",&t);
while (t--){
scanf("%d",&n);
for (i=0;i<n;i++){
scanf("%d%d",&stick[i].l,&stick[i].w);
num[i]=0;
}
sort(stick,stick+n,cmpl);
k=1;
for (i=0;i<n;i++){
for (j=0;j<k;j++)
if (stick[i].w>=num[j]){
num[j]=stick[i].w;
break;
}
if (j>=k){
num[k]=stick[i].w;
k++;
}
}
printf("%d\n",k);
}
return 0;
}