链接:http://acm.hdu.edu.cn/showproblem.php?pid=5971
Wrestling MatchProblem Description Nowadays, at least one wrestling match is held every year in our country. There are a lot of people in the game is "good player”, the rest is "bad player”. Now, Xiao Ming is referee of the wrestling match and he has a list of the matches in his hand. At the same time, he knows some people are good players,some are bad players. He believes that every game is a battle between the good and the bad player. Now he wants to know whether all the people can be divided into "good player" and "bad player".
Input Input contains multiple sets of data.For each set of data,there are four numbers in the first line:N (1 ≤ N≤ 1000)、M(1 ≤M ≤ 10000)、X,Y(X+Y≤N ),in order to show the number of players(numbered 1toN ),the number of matches,the number of known "good players" and the number of known "bad players".In the next M lines,Each line has two numbersa, b(a≠b) ,said there is a game between a and b .The next line has X different numbers.Each number is known as a "good player" number.The last line contains Y different numbers.Each number represents a known "bad player" number.Data guarantees there will not be a player number is a good player and also a bad player.
Output If all the people can be divided into "good players" and "bad players”, output "YES", otherwise output "NO".
Sample Input 5 4 0 0 1 3 1 4 3 5 4 5 5 4 1 0 1 3 1 4 3 5 4 5 2
Sample Output NO YES
|
代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
#include <cmath>
#include <cctype>
#include <vector>
#include <stack>
#include <map>
#include <bitset>
#include <set>
#include <ctime>
#include <cstdlib>
#include <algorithm>
using namespace std;
long long n,m,x,y,a,b;
long long father[20001],fs[10001];
int find(int x)//查集
{
if(x!=father[x])
father[x]=find(father[x]);
return father[x];
}
int unity(int x,int y)//并集
{
int r1=find(father[x]),r2=find(father[y]);
father[r1]=r2;
}
int main()
{
while(~scanf("%lld %lld %lld %lld",&n,&m,&x,&y))
{
for(int i=1;i<=2*n;i++)
{
father[i]=i;// //对于每种生物:把x 存为本身,x+n 存为天敌
fs[i]=0;
}
int flag=1;
for(int i=1;i<=m;i++)
{
scanf("%lld %lld",&a,&b);
fs[a]=1;
fs[b]=1;
if(find(a)==find(b+n)&&find(a+n)==find(b))
{
continue;
}
else if(find(a)==find(b))
{
flag=0;
}
else
{
unity(a,b+n);
unity(b,a+n);
}
}
int u=0,v;
for(int i=1;i<=x;i++)
{
scanf("%lld",&v);
if(flag==0)
continue;
fs[v]=1;
if(find(v)==v)
continue;
if(u==0)
{
u=find(v);
}
else
{
if(find(v)==u)
continue;
else
flag=0;
}
}
u=0;
for(int i=1;i<=y;i++)
{
scanf("%lld",&v);
if(flag==0)
continue;
fs[v]=1;
if(find(v)==v)
continue;
if(u==0)
{
u=find(v);
}
else
{
if(find(v)==u)
continue;
else
flag=0;
}
}
if(flag==0)
printf("NO\n");
else
{
int ff=1;
for(int i=1;i<=n;i++)
{
if(fs[i]==0)
{
ff=0;
break;
}
}
if(ff==1)
printf("YES\n");
else
printf("NO\n");
}
}
return 0;
}