题目描述
大家应该都会玩“锤子剪刀布”的游戏:两人同时给出手势,胜负规则如图所示:
现给出两人的交锋记录,请统计双方的胜、平、负次数,并且给出双方分别出什么手势的胜算最大。
输入格式:
输入第 1 行给出正整数 N(≤10的5次方 ),即双方交锋的次数。随后 N 行,每行给出一次交锋的信息,即甲、乙双方同时给出的的手势。C
代表“锤子”、J
代表“剪刀”、B
代表“布”,第 1 个字母代表甲方,第 2 个代表乙方,中间有 1 个空格。
输出格式:
输出第 1、2 行分别给出甲、乙的胜、平、负次数,数字间以 1 个空格分隔。第 3 行给出两个字母,分别代表甲、乙获胜次数最多的手势,中间有 1 个空格。如果解不唯一,则输出按字母序最小的解。
输入样例:
10
C J
J B
C B
B B
B C
C C
C B
J B
B C
J J
输出样例:
5 3 2
2 3 5
B B
代码
package com.hbut.pat;
import java.util.Scanner;
public class Pat_1018 {
static String bidui(int a[]) {
if(a[0]>a[1]&&a[0]>a[2]) {
return "B" ;}
else if(a[1]>a[0]&&a[1]>a[2]) {
return"C";}
else if(a[2]>a[0]&&a[2]>a[1]){
return"J";}
else if(a[0]==a[1]&&a[0]>a[2]){
return"B";}
else if(a[0]>a[1]&&a[0]==a[2]){
return"B";}
else if(a[1]>a[0]&&a[1]==a[2]){
return"C";}
else if(a[0]==a[1]&&a[0]==a[2]){
return"B";}
return null;
}
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int a=sc.nextInt();sc.nextLine();
char ar[][]=new char [a][2];
int j[]=new int [3];
int jh[]=new int [3];
int y[]=new int [3];
int yh[]=new int [3];
for(int i=0;i<ar.length;i++) {
String aq[]=sc.nextLine().split(" ");
ar[i][0]=aq[0].charAt(0);
ar[i][1]=aq[1].charAt(0);
if(ar[i][0]==ar[i][1]) {
j[1]++;
y[1]++;
}
else if(ar[i][0]=='C'&&ar[i][1]=='J'||ar[i][0]=='J'&&ar[i][1]=='B'||ar[i][0]=='B'&&ar[i][1]=='C' ){
j[0]++;
y[2]++;
if(ar[i][0]=='B')jh[0]++;
else if(ar[i][0]=='C')jh[1]++;
else if(ar[i][0]=='J')jh[2]++;
}
else if(ar[i][0]=='J'&&ar[i][1]=='C'||ar[i][0]=='B'&&ar[i][1]=='J'||ar[i][0]=='C'&&ar[i][1]=='B' ){
y[0]++;
j[2]++;
if(ar[i][1]=='B')yh[0]++;
else if(ar[i][1]=='C')yh[1]++;
else if(ar[i][1]=='J')yh[2]++;
}
}
System.out.println(j[0]+" "+j[1]+" "+j[2]);
System.out.println(y[0]+" "+y[1]+" "+y[2]);
System.out.println(bidui(jh)+" "+bidui(yh));
}
}