Description
有n个人围成一圈,按顺序从1到n编好号。从第一个人开始报数,报到3的人退出圈子,下一个人从1开始报数,报到3的人退出圈子。如此下去,直到留下最后一个人。请按退出顺序输出退出圈子的人的编号。
Input
多组测试数据,每组输入一个整数n,表示有n个人围成一圈。
Output
请按退出顺序输出退出圈子的人的编号。
Sample Input
5
9
Sample Output
3 1 5 2 4
3 6 9 4 8 5 2 7 1
#include <stdio.h>
#include <stdlib.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int main(int argc, char *argv[]) {
int n;
while(scanf("%d",&n)!=EOF){
int i;
int a[n];
//赋值
for (i=0;i<n;i++)
a[i]=i+1;
int count=0,baoshu=1,xu=1;
//报数开始
while(count!=n-1){
if(a[xu-1]!=0)//判断是否退出
{
//退出
if(baoshu==3)
{
baoshu=1;
count++;
printf("%d ",a[xu-1]);//输出退出
a[xu-1]=0;//标记退出
}else{baoshu++;}
}
//加序号
if(xu==n)
xu=1;
else
xu++;
}
//输出最后一个
for (i=0;i<n;i++){
if(a[i]!=0)
printf("%d\n",a[i]);
}
}
return 0;
}