There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

C++版本一

BFS

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <queue>

using namespace std;
int t,m,n,ans;
int k,x1,x2,y1,y2;
char dfs[110][110];
//int vis[110][110];
int a[4]={1,-1,0,0};
int b[4]={0,0,1,-1};


struct node
{
     int x;
     int y;
}front1,tmp,start;
    queue <node>Q;

bool prime(int x,int y){

	if(tmp.x>=0&&tmp.x<n&&tmp.y>=0&&tmp.y<m)
	return true;
	else
    return false;


}
void bfs(node s){

    while(!Q.empty())
        Q.pop();

	Q.push(s);
    while(!Q.empty()){
        front1=Q.front();
        Q.pop();

        for(int i=0;i<4;i++){

            tmp.x=a[i]+front1.x;
            tmp.y=b[i]+front1.y;
            if(prime(tmp.x,tmp.y)&&dfs[tmp.x][tmp.y]!='#'){
                dfs[tmp.x][tmp.y]='#';
               // printf("%d  %d %d\n",tmp.x,tmp.y,i);
               	ans++;
                Q.push(tmp);
          	}
        }
    }
}

int main()
{

     while  (scanf("%d%d",&m,&n)!=EOF) {
        if(m==0&&n==0)break;
   //   memset(vis,0,sizeof(vis));
        memset(dfs,'0',sizeof(dfs));
        getchar();
        for(int i=0;i<n;i++){
            scanf("%s",dfs[i]);
            for(int j=0;j<m;j++){
                if(dfs[i][j]=='@')
                {
                    x1=i;
                    y1=j;
                    break;
                }

            }
            getchar();
        }


                start.x=x1;
                start.y=y1;
                dfs[x1][y1]='#';
                ans=1;
                bfs(start);


            printf("%d\n",ans);

    }
    return 0;
}

C++版本二

DFS

#include<iostream>
#include <cstdio>//getchar()头文件
using namespace std;
char a[25][25];
int dir[4][2]=
{
    {1,0}, //向右
    {-1,0},//向左
    {0,1}, //向上
    {0,-1} //向下
};
int x,y,num;
bool YES(int x0,int y0)//xx,yy
{
   //x--列,y--行
    if(x0<y&&x0>=0&&y0>=0&&y0<x)
        return true;
    else
        return false;
}
void DFS(int x0,int y0)
{
    a[x0][y0]='#';
    num++;
    int xx,yy;
    for(int i=0; i<4; i++)
    {
        int xx=x0+dir[i][0];
        int yy=y0+dir[i][1];
        if(YES(xx,yy)&&a[xx][yy]=='.')
            DFS(xx,yy);
    }
 
}
int main()
{
    int i,j,di,dj;
    while (scanf("%d%d",&x,&y)!=EOF)
    {
        getchar();
        if (x==0&&y==0) break;
        for (i=0; i<y; i++)
        {
            for (j=0; j<x; j++)
            {
                scanf("%c",&a[i][j]);
                if(a[i][j] == '@')
                {
                    di = i;
                    dj = j;
                }
            }
            getchar();
        }
        num=0;
        DFS(di,dj);
        cout<<num<<endl;
 
    }
    return 0;
}

C++版本三

BFS

#include<cstdio>
#include<queue>
using namespace std;
char a[25][25];
int x,y,sum;
int dir[4][2]={1,0,0,1,-1,0,0,-1};
struct node
{
    int x,y;
}q[500];
bool YES(int x0,int y0)//xx,yy
{
   //x--列,y--行
    if(x0<y&&x0>=0&&y0>=0&&y0<x)
        return true;
    else
        return false;
}
void BFS(int x0,int y0)
{
    queue<node>q;
    node start,endd;
    start.x=x0;
    start.y=y0;
    q.push(start);
    while(!q.empty())
    {
        start=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            endd.x=start.x+dir[i][0];
            endd.y=start.y+dir[i][1];
            if(YES(endd.x,endd.y)&&a[endd.x][endd.y]=='.')
            {
                a[endd.x][endd.y]='#';
                sum++;
                q.push(endd);
            }
        }
    }
}
int main()
{
    int i,j,di,dj;
    while (scanf("%d%d",&x,&y)!=EOF)
    {
        getchar();
        if (x==0&&y==0) break;
        for (i=0; i<y; i++)
        {
            for (j=0; j<x; j++)
            {
                scanf("%c",&a[i][j]);
                if(a[i][j] == '@')
                {
                    di = i;
                    dj = j;
                }
            }
            getchar();
        }
        sum=1;
        BFS(di,dj);
        printf("%d\n",sum);
    }
    return 0;
}

C语言版本一

BFS

#include<cstdio>
#include<queue>
using namespace std;
int a[25][25];
int x,y,sum;
int dir[4][2]={1,0,0,1,-1,0,0,-1};
struct node
{
    int x,y;
}q[500];
bool YES(int x0,int y0)//xx,yy
{
   //x--列,y--行
    if(x0<y&&x0>=0&&y0>=0&&y0<x)
        return true;
    else
        return false;
}
void BFS(int x0,int y0)
{
    int head=0,tail=1;
    q[1].x=x0;
    q[1].y=y0;
    while(head<tail)
    {
        ++head;
        for(int i=0;i<4;i++)
        {
            int x1=q[head].x+dir[i][0];
            int y1=q[head].y+dir[i][1];
            if(YES(x1,y1)&&a[x1][y1]=='.')
            {
                a[x1][y1]='#';
                sum++;
                q[++tail].x=x1;
                q[tail].y=y1;
            }
        }
    }
}
int main()
{
    int i,j,di,dj;
    while (scanf("%d%d",&x,&y)!=EOF)
    {
        getchar();
        if (x==0&&y==0) break;
        for (i=0; i<y; i++)
        {
            for (j=0; j<x; j++)
            {
                scanf("%c",&a[i][j]);
                if(a[i][j] == '@')
                {
                    di = i;
                    dj = j;
                }
            }
            getchar();
        }
        sum=1;
        BFS(di,dj);
        printf("%d\n",sum);
    }
    return 0;
}