在线处理
-
定义: 在线 的意思是指每输入一个数据就进行 即是处理 ,在任何一个地方终止输入,算法都能能正确给出当前解
- 特点:数据只需一次扫描,便可给出结果,无需在主机内存进行存储;并且在任何时刻,此算法都能根据输入给出正确结果。
- 此算法非常高效,时间复杂度仅为0(N)
例题: HDU 1003 Max Sum
Max SumTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 299181 Accepted Submission(s): 71008 Problem Description Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
|
#include <stdio.h>
int main(){
int t, n, maxLeft, maxRight, maxSum, temp;
int thisLeft, thisSum;
scanf("%d", &t);
for(int id = 1; id <= t; ++id){
scanf("%d", &n);
scanf("%d", &maxSum);
thisLeft = maxLeft = maxRight = 0;
thisSum = maxSum;
if(thisSum < 0){ thisSum = 0; thisLeft = 1; }
for(int i = 1; i < n; ++i){
scanf("%d", &temp);
thisSum += temp;
if(thisSum > maxSum){
maxSum = thisSum;
maxLeft = thisLeft;
maxRight = i;
}
if(thisSum < 0){
thisLeft = i + 1;
thisSum = 0;
}
}
printf("Case %d:\n%d %d %d\n", id, maxSum, maxLeft + 1, maxRight + 1);
if(id != t) printf("\n");
}
return 0;
}